Установка centos 7 на vmware workstation

Тема в разделе "Десктопный Linux", создана пользователем Anatoli777, 3 мар 2016.

  1. Anatoli777

    Anatoli777

    Регистр.:
    19 мар 2013
    Сообщения:
    183
    Симпатии:
    33
    Установил centos 7 на vmware workstation, но после запуска в терминале появляется сообщение:
    [user@if-you-see-this-then-your-dns-resolver-is-wrong Desktop]$ . Как это можно исправить?
     
  2. winsdor

    winsdor

    Регистр.:
    25 май 2010
    Сообщения:
    152
    Симпатии:
    59
    Попробуй в vmware поизменять тип сетевого подключения.
     
  3. Anatoli777

    Anatoli777

    Регистр.:
    19 мар 2013
    Сообщения:
    183
    Симпатии:
    33
    Параметры виртуальной машины.jpg
    Пробовал включать по очереди мост и Nat. А больше я не знаю, что включить
     
  4. winsdor

    winsdor

    Регистр.:
    25 май 2010
    Сообщения:
    152
    Симпатии:
    59
    Да я собсно это и имел ввиду, не помогло? Что-то подобное описывается здесь, возможно там один из ответов вам подойдет.
     
  5. Anatoli777

    Anatoli777

    Регистр.:
    19 мар 2013
    Сообщения:
    183
    Симпатии:
    33
    Посмотрел, но не понял,что можно взять из того примера.
     
  6. rsscenter

    rsscenter Создатель

    Регистр.:
    25 фев 2014
    Сообщения:
    13
    Симпатии:
    0
    Посмотрите пингуются ли внешние ip (например ping 8.8.8.8)?
    Eсли пингуются, то попробуйте в настройках задать dns явно:

    # cat /etc/resolv.conf

    nameserver 192.168.x.x
    nameserver 8.8.8.8
    nameserver 8.8.4.4
     
  7. Anatoli777

    Anatoli777

    Регистр.:
    19 мар 2013
    Сообщения:
    183
    Симпатии:
    33
    ping 8.8.8.8
    connect: Сеть недоступна
     
  8. rsscenter

    rsscenter Создатель

    Регистр.:
    25 фев 2014
    Сообщения:
    13
    Симпатии:
    0
    А что выдает
    # ifconfig
    ?
     
  9. Anatoli777

    Anatoli777

    Регистр.:
    19 мар 2013
    Сообщения:
    183
    Симпатии:
    33
    Изменил подключение на Nat. стало пинговаться.
     
  10. rsscenter

    rsscenter Создатель

    Регистр.:
    25 фев 2014
    Сообщения:
    13
    Симпатии:
    0
    Скорее всего у Вас проблема не с Centos а с настройкой сети в vmware workstation
    самый простой вариант мостовое соединение, оба интерфейса находятся в одном диапазоне ip адресов
    с настойкой сети в wm Вам возможно поможет http://blog.pskovsoft.com/emulation/nastroyka-seti-v-vmware-workstation.html